We will be undergoing scheduled maintenance during this time.
Posted Jul 20, 2026 - 09:57 UTC
Scheduled
One of our partner carrier has a scheduled maintenance window on Friday, July 24th 2026 starting at 00:00 UTC.
During this window, their team will perform work that supports the continued reliability and performance of their platform. We do not expect a substantial impact on users, however, the ability to make and receive calls and messages (SMS/MMS) may be effected for up to 60 minutes during this maintenance.
The maintenance will be carried out with the following schedule: 00:00AM – 01:00AM UTC 10:00AM – 11:00AM Sydney (AEDT) 02:00AM – 03:00AM Paris (CEST) 08:00PM – 09:00PM New York (EDT)
Posted Jul 17, 2026 - 14:24 UTC
This scheduled maintenance affects: Voice — Calling (Inbound Calls, Outbound Calls) and Messaging (Inbound Messaging (SMS/MMS), Outbound Messaging (SMS/MMS)).