Errors saving E911 emergency location for some customers

Incident Report for Aircall

Resolved

Our partner carrier has fully resolved the issue and service is back to normal at this time
Posted Jul 15, 2026 - 16:03 UTC

Identified

Some customers may experience issues setting or changing their registered E911 emergency location at this time. Our carrier partner has identified a problem with their system that is causing this problem and they are currently working on a fix.
Posted Jul 15, 2026 - 15:43 UTC
This incident affected: Aircall Dashboard (Numbers Management (Purchase, Porting, Compliance)).