Analytics not displaying data

Incident Report for Aircall

Resolved

We have received positive feedback from our provider, and Analytics Dashboards are now loading correctly.

We appreciate your patience and understanding while we worked to restore normal functionality.
Posted Sep 02, 2025 - 17:50 UTC

Update

We are continuing to work on a potential fix with our provider for this issue.
We will update this incident as soon as more information becomes available
Posted Sep 02, 2025 - 15:28 UTC

Identified

The issue has been identified and we are exploring a fix implementation.
Posted Sep 02, 2025 - 14:14 UTC

Investigating

We are currently investigating reports of Analytics not displaying data. We will be providing feedback as soon as progress is made.
Posted Sep 02, 2025 - 14:08 UTC
This incident affected: Aircall Dashboard (Analytics).