Dashboard Performance Issues

Incident Report for Aircall

Resolved

The error loading recordings and insights has been fully resolved, and the Dashboard is performing normally.
Posted Jun 04, 2026 - 07:49 UTC

Monitoring

A fix has been implemented, and we are noticing significant improvements in Dashboard loading time.
Posted Jun 04, 2026 - 07:22 UTC

Investigating

We are currently investigating an issue with the Dashboard freezing or crashing when accessing call recordings.
Posted Jun 04, 2026 - 07:04 UTC
This incident affected: Aircall Dashboard (Conversation Center).