Issues with phone calls impacting Mexico phone numbers

Incident Report for Aircall

Resolved

Voice service for Mexico phone numbers has been fully restored. The issue was isolated to a local carrier, which has since returned to normal operation.
Posted May 28, 2026 - 20:11 UTC

Monitoring

The issue seems to be subscribed to a local carrier or local network and has returned to regular service.

We continue to monitor the situation to ensure voice service remains stable.
Posted May 28, 2026 - 19:40 UTC

Investigating

We are currently investigating an issue with Mexico phone numbers.
Posted May 28, 2026 - 19:22 UTC
This incident affected: Voice — Calling (Inbound Calls, Outbound Calls).