Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 09, 2025 - 03:00 UTC
Scheduled
Aircall has a scheduled maintenance window on Saturday, August 9th 2025 starting at 03:00AM UTC.
During this time, our team will be performing maintenance as part of our ongoing commitment to improving the reliability and performance of our platform.
You may experience Live Monitoring disruption during the maintenance window, such as : * error messages on the Live Monitoring Dashboard * Live Monitoring dashboard doesn't load any data upon opening
The maintenance will be carried out with the following schedule: 03:00AM – 05:00AM UTC 01:00PM – 03:00PM Sydney (AEST) 04:00AM – 06:00AM London (BST) 11:00PM – 01:00AM New York (EDT)
Posted Aug 05, 2025 - 13:50 UTC
This scheduled maintenance affected: Aircall Dashboard (Live Monitoring).