We still have not seen any direct impact to customers, so this incident is resolved
Posted Sep 01, 2026 - 19:27 UTC
Monitoring
Thus far we have not detected any direct impact to our customers, but we will continue to monitor
Posted Sep 01, 2026 - 19:02 UTC
Update
We are continuing to investigate this issue.
Posted Sep 01, 2026 - 18:45 UTC
Investigating
Our monitoring systems have detected a potential issue with MMS messages delayed delivery. We will update this page with more information when possible
Posted Sep 01, 2026 - 18:43 UTC
This incident affected: Messaging (Outbound Messaging (SMS/MMS)).