Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 27, 2025 - 06:00 UTC
Scheduled
Aircall has a scheduled maintenance window on Friday, June 27th starting at 06:00 UTC. During this time, our team will be performing changes to Aircall Status Page.
No impact is expected to Aircall products and services. In case your access to status.aircall.io is temporarily impacted, we advise to reload the website or clear cache and cookies.
The maintenance will be carried out with the following schedule: 06:00 – 08:00 UTC 4:00PM – 6:00PM Sydney (AEST) 7:00AM – 9:00AM London (BST) 2:00AM – 4:00AM New York (EDT)
Posted Jun 26, 2025 - 08:53 UTC
This scheduled maintenance affected: Websites (Aircall Status Page).