Analytics Dashboards Slow Loading

Incident Report for Aircall

Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 08:45 UTC

Monitoring

We observe a return to normal performance with loading times.
We keep monitoring the results.
Posted Jul 09, 2026 - 08:21 UTC

Investigating

We are currently investigating a performance issue that is impacting Analytics and Call History loading time
Posted Jul 09, 2026 - 07:46 UTC
This incident affected: Aircall Dashboard (Analytics).