Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 12, 2026 - 07:00 UTC
Scheduled
Aircall has a scheduled maintenance window on Saturday, September 12th 2026 starting at 7:00 UTC.
During this window, our team will perform work that supports the continued reliability and performance of the Aircall platform. You may experience messaging disruption of a few seconds during the maintenance window, such as : * inbound calls won't be dispatched to agents * dispatched calls won't be answered * in-call actions may fail * calls may get stuck
The maintenance will be carried out with the following schedule: 07:00AM – 08:00AM UTC 05:00PM – 06:00PM Sydney (AEDT) 09:00AM – 10:00AM Paris (CEST) 03:00AM – 04:00AM New York (EDT)
Posted Sep 08, 2026 - 14:38 UTC
This scheduled maintenance affected: Voice — Calling (Inbound Calls).