The Analytics section and Live Monitoring+ in the Aircall Dashboard are now loading as expected. We appreciate your patience while we worked to restore normal performance.
Posted Aug 18, 2025 - 20:19 UTC
Monitoring
A fix has been implemented for the issues impacting the Analytics section and Live Monitoring+ in the Aircall Dashboard. We are monitoring performance to ensure the services are fully stabilized.
Posted Aug 18, 2025 - 19:35 UTC
Update
We continue to investigate performance issues affecting the Analytics section and Live Monitoring+ in the Aircall Dashboard. Users may experience slow loading or delays. Our team has identified the root causes and is working on implementing fixes.
Posted Aug 18, 2025 - 14:08 UTC
Identified
We are investigating an issue causing the Analytics section of the Aircall Dashboard to load slowly. Our team has identified the root cause and is working on a fix.
Posted Aug 18, 2025 - 13:35 UTC
This incident affected: Aircall Dashboard (Analytics, Live Monitoring).