We can confirm that the issue with the French eSIM partner has been fully resolved. We appreciate your patience and understanding while we worked with our partners to restore normal functionality.
Posted Aug 11, 2026 - 12:30 UTC
Monitoring
A fix was implemented by our Partner. We are currently monitoring the results.
Posted Aug 11, 2026 - 11:50 UTC
Investigating
We are currently investigating issues impacting French eSIM numbers. The issue seems to have its origin with our Carrier Partner.